PHPのバージョンの互換性を確認できるワードプレスプラグイン

先日、ワードプレスの管理画面を開くと
「PHPの更新が必要です」というメッセージが。

別のワードプレスでも
同じようにメッセージが表示されていたので
いつものように適当にPHPを変えてみて
そちらはなんとか上手くいったのだけれど・・・

このThinkPadのワードプレスは上手くいかず
「技術的な問題があります」と表示されてしまう。

そういえば以前、ワードプレスの公式サイトで
PHPのバージョンの互換性を確認できるプラグイン
というものがあるとかなんとか書いてあったような・・・

調べてみると、このプラグインが紹介されていました。
PHP Compatibility Checker

PHP Compatibility Checker

PHPのプログラミング知識がなくても
今使っているワードプレスのテーマやプラグインが
どのPHPバージョンに対応しているかの
互換性をチェックしてくれるものです。

早速ダウンロードして
php73との互換性を調べてみたところ
いくつかのプラグインが対応していないことがわかりました。

こ、これは、便利・・・

それらは使用停止しても
特には問題ないプラグインだったので
テストした上で、削除。

おかげでスムーズに
php73に切り替えることができました。

エラーが出ていたプラグインは
けっこう昔に入れたものだったので
バージョンアップもされておらず
対応できなかったのかなと思います。

ワードプレスサーバーの
PHPバージョンアップについてお困りの方がいらしたら
ぜひ試してみてください。